Tag Archives: iPhone Games

Download Grand Theft Auto San Andreas 1.0.2 For iPhone and iPad – TFP

Grand Theft Auto San Andreas 1.0.2 For iPhone and iPad – TFP
Download Grand Theft Auto San Andreas 1.0.2 For iPhone and iPad - TFP
About This Game:
Again, fans of Rockstar company with a fresh copy of series GTA games for the iPhone and iPad pleased. He turns to one of the company’s most popular game GTA: San Andreas is reached. The beautiful game in the role of Carl Johnson after a long absence from Los Santos, while there has returned to her mother died and the family has many problems. She returned to the town and neighborhood, and a lot of work to do on its own. In this version of the game, the graphics for the iPhone and iPad 4 and above 5 and above has improved. To run this game iPhone 4s and above, iPod Touch 5 and iPad 2 and higher and higher need. Also you need to run the game to iOS 4.3 and above.
Read More »

Download Asphalt 8 Airborne v1.2.0 ipa ios (iPad iPhone iPod)

Asphalt 8 Airborne v1.2.0 ipa ios (iPad iPhone iPod)
Download Asphalt 8 Airborne v1.2.0 ipa ios (iPad iPhone iPod)
About This Game:
Requirements: Compatible with iPhone 4, iPhone 4S, iPhone 5, iPod touch (4th generation), iPod touch (5th generation), iPad 2 Wi-Fi, iPad 2 Wi-Fi + 3G, iPad (3rd generation), iPad Wi-Fi + 4G, iPad (4th generation), iPad Wi-Fi + Cellular (4th generation), iPad mini and iPad mini Wi-Fi + Cellular. Requires iOS 5.0 or later. This app is optimized for iPhone 5.

**You need a jailbroken iOS device to play this**
Read More »

Download Asphalt 8 Airborne v1.0.0 ipa ios (iPad iPhone iPod)

Asphalt 8 Airborne v1.0.0 ipa ios (iPad iPhone iPod)
Download Asphalt 8 Airborne v1.0.0 ipa ios (iPad iPhone iPod)
About This Game:
Requirements: Compatible with iPhone 4, iPhone 4S, iPhone 5, iPod touch (4th generation), iPod touch (5th generation), iPad 2 Wi-Fi, iPad 2 Wi-Fi + 3G, iPad (3rd generation), iPad Wi-Fi + 4G, iPad (4th generation), iPad Wi-Fi + Cellular (4th generation), iPad mini and iPad mini Wi-Fi + Cellular. Requires iOS 5.0 or later. This app is optimized for iPhone 5.
 
**You need a jailbroken iOS device to play this**
Read More »